Skip to main content
VulnerabilityPublished Updated

CVE-2025-1220: Php · Null byte termination in hostnames

Affects phpSource GCVE Database

0
Authoritative record:CVE-2025-1220· Low 3.7

Not known to be exploited · CVSS 3.7 Low · fixed in 8.4.10 : update php when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.10, 8.3.23, 8.2.29 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/php package to 8.4.10, 8.3.23, 8.2.29 or 8.1.33.

Affected software

ProductAffectedFixed in
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • =8.1.0
  • <8.1.33
  • =8.2.0
  • <8.2.29
  • =8.3.0
  • <8.3.23
  • =8.4.0
  • <8.4.10
Fixed in
  • 8.1.33
  • 8.2.29
  • 8.3.23
  • 8.4.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected PHP versions. Red Hat has released updated packages for Red Hat Enterprise Linux 8 that fix this vulnerability. Users should update to PHP versions 8.1.33 or later, 8.2.29 or later, 8.3.23 or later, or 8.4.10 or later as appropriate. Refer to the Red Hat advisory RHSA-2026:1412 for detailed update instructions.

Description

A vulnerability in PHP versions 8.1 before 8.1.33, 8.2 before 8.2.29, 8.3 before 8.3.23, and 8.4 before 8.4.10 allows null byte characters in hostnames passed to functions like fsockopen(). This can cause inconsistent hostname parsing by other functions such as parse_url(), potentially leading to security issues if user code relies on these functions for access control. Red Hat has issued security updates addressing this issue.

References

Community reviews

Loading reviews…