Skip to main content
CVE-2024-6239VulnerabilityPublished Updated

SUSE poppler · security update for poppler

Affects SUSE popplerSource GCVE Database

0
Authoritative record:CVE-2024-6239· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade the Red Hat redhat/poppler package to 9.5.0 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/poppler package to 9.5.0.

Affected software

ProductAffectedFixed in
Red Hatredhat/popplerpkg:rpm/redhat/popplerOther threatsAffected
  • <9.5.0
Fixed in
  • 9.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official security update is available from Red Hat to address this vulnerability. Users should apply the update as detailed in Red Hat Advisory RHSA-2024:9167 and the linked Red Hat documentation. No additional mitigation steps are required beyond applying the official patch.

Description

A moderate severity vulnerability (CVE-2024-6239) exists in the Poppler PDF rendering library, specifically causing a crash in the pdfinfo utility when processing malformed PDF documents with the -dests parameter. This issue affects Poppler versions used in Red Hat Enterprise Linux 9 and related distributions. Red Hat has released an official security update to address this vulnerability. No known exploits have been reported in the wild. Users of affected systems are advised to apply the provided update to mitigate the issue.

References

Community reviews

Loading reviews…