Skip to main content
CVE-2024-10976VulnerabilityPublished Updated

Red Hat Security Advisory: postgresql:13 security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · fixed in 17.1.0 : update Red Hat when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.1.0, 16.5.0, 15.9.0 +2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Red Hatredhat/postgresqlpkg:rpm/redhat/postgresqlOther threatsAffected
  • >=9
Fixed in–
Bitnamipostgresqlpkg:bitnami/postgresqlOther threatsAffected
  • <13.17.0
  • >=14.0.0 <14.14.0
  • >=15.0.0 <15.9.0
  • >=16.0.0 <16.5.0
  • >=17.0.0 <17.1.0
Fixed in
  • 13.17.0
  • 14.14.0
  • 15.9.0
  • 16.5.0
  • 17.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated PostgreSQL packages for Red Hat Enterprise Linux 9 to address these vulnerabilities. Users should apply these official updates promptly. For detailed update instructions, refer to Red Hat's advisory and article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the provided patches.

Description

Incomplete tracking in PostgreSQL of tables with row security allows a reused query to view or change different rows from those intended. CVE-2023-2455 and CVE-2016-2193 fixed most interaction between row security and user ID changes. They missed cases where a subquery, WITH query, security invoker view, or SQL-language function references a table with a row-level security policy. This has the same consequences as the two earlier CVEs. That is to say, it leads to potentially incorrect policies being applied in cases where role-specific policies are used and a given query is planned under one role and then executed under other roles. This scenario can happen under security definer functions or when a common user and query is planned initially and then re-used across multiple SET ROLEs. Applying an incorrect policy may permit a user to complete otherwise-forbidden reads and modifications. This affects only databases that have used CREATE POLICY to define a row security policy. An attacker must tailor an attack to a particular application's pattern of query plan reuse, user ID changes, and role-specific row security policies. Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.

References

Community reviews

Loading reviews…