Skip to main content
CVE-2024-4317VulnerabilityPublished Updated

CVE-2024-4317: PostgreSQL pg_stats_ext and pg_stats_ext_exprs lack authorization checks

Affects postgresqlSource GCVE Database

0

Not known to be exploited · fixed in 16.3.0 : update postgresql when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.3.0, 15.7.0, 14.12.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade postgresql to 16.3.0, 15.7.0 or 14.12.0.

Affected software

ProductAffectedFixed in
postgresqlAffected
  • >=14.0.0 <14.12.0
  • >=15.0.0 <15.7.0
  • >=16.0.0 <16.3.0
Fixed in
  • 14.12.0
  • 15.7.0
  • 16.3.0

AI-suggested

A patch is available for this vulnerability. Users should upgrade PostgreSQL to versions 14.12 or later, 15.7 or later, and 16.3 or later to remediate the issue. For existing PostgreSQL installations, simply installing the updated version is insufficient; administrators must follow the specific instructions in the PostgreSQL release notes and Red Hat advisory RHSA-2024:5927 to fully mitigate the vulnerability. Refer to https://access.redhat.com/articles/11258 for detailed update and remediation guidance.

Description

PostgreSQL versions 14, 15, and 16 prior to 14.12, 15.7, and 16.3 respectively have a vulnerability in the built-in views pg_stats_ext and pg_stats_ext_exprs. These views lack proper authorization checks, allowing unprivileged database users to read statistical data, including most common values from CREATE STATISTICS commands of other users. This exposure may reveal sensitive column values or function results that the user should not access. The vulnerability affects existing installations unless they follow specific upgrade instructions. A patch is available to fix this issue.

References

Community reviews

Loading reviews…