Skip to main content
CVE-2026-103484VulnerabilityPublished

Red Hat Security Advisory: postgresql:16 security update

Affects Red Hat postgresql:16Source GCVE Database

0
Compare
Authoritative record:CVE-2026-103484· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade Red Hat pgvector to 0.8.7 soon.

Data as of 2 Nov 2026, 06:30 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.8.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade pgvector and pgvector/pgvector to 0.8.7.

Affected software

ProductAffectedFixed in
pgvectorAffected
  • <0.8.7
Fixed in
  • 0.8.7
GitHubpgvector/pgvectorpkg:github/pgvector/pgvectorOther threatsAffected
  • <0.8.7
Fixed in
  • 0.8.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for PostgreSQL 16 on Red Hat Enterprise Linux 9.6 Extended Update Support that fixes this vulnerability. Users should apply the update as described in Red Hat advisory RHSA-2026:93460 and the linked article https://access.redhat.com/articles/11258 to remediate the issue. No additional mitigation steps are indicated beyond applying the official patch.

Description

A security vulnerability (CVE-2026-103484) in the pgvector extension of PostgreSQL allows arbitrary code execution via an out-of-bounds write during the IVFFlat index build process. This issue affects PostgreSQL 16 as packaged for Red Hat Enterprise Linux 9.6 Extended Update Support. Red Hat has issued an important security update to address this flaw.

References

Community reviews

Loading reviews…