Skip to main content
CVE-2024-28102VulnerabilityPublished Updated

SUSE · security update for python-jwcrypto

Affects SUSESource GCVE Database

0

Not known to be exploited · fixed in 9.8 : update SUSE when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6, 9.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade SUSE to 9.8, 9.6 or 9.4.

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=9.0 <9.4
  • >=9.4 <9.6
  • >=9.6 <9.8
Fixed in
  • 9.4
  • 9.6
  • 9.8

AI-suggested

A security update fixing this vulnerability is available from Red Hat. Users should apply the updated python-jwcrypto packages as provided in Red Hat Advisory RHSA-2024:2559. Ensure all previously released errata relevant to the system are applied before updating. No additional mitigation steps are indicated by the vendor.

Description

A denial of service vulnerability (CVE-2024-28102) exists in the python-jwcrypto package used in Red Hat Enterprise Linux 9 and related distributions. The issue occurs when processing malicious JSON Web Encryption (JWE) tokens, causing the application to become unresponsive. Red Hat has issued security updates to address this vulnerability. The fix is available and should be applied to affected systems to prevent denial of service conditions.

References

Community reviews

Loading reviews…