Skip to main content
CVE-2024-53899VulnerabilityPublished Updated

Red Hat Security Advisory: python36:3.6 security update

Affects Red Hat python36:3.6Source GCVE Database

0
Compare
Authoritative record:CVE-2024-53899· High 8.4

Not known to be exploited · CVSS 8.4 High : upgrade Red Hat virtualenv to 20.26.6 soon.

Data as of 3 Nov 2026, 18:01 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 20.26.6
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade virtualenv to 20.26.6.

Affected software

ProductAffectedFixed in
PyPIvirtualenvpkg:pypi/virtualenvOther threatsAffected
  • <20.26.6
Fixed in
  • 20.26.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an update for the python36:3.6 module that addresses this vulnerability. Users of Red Hat Enterprise Linux 8 should apply the update as described in Red Hat Advisory RHSA-2024:10953. The vendor manages remediation through this official fix. No additional mitigation steps are indicated beyond applying the update.

Description

A security update for the python36:3.6 module in Red Hat Enterprise Linux 8 addresses a vulnerability in the virtualenv package that could allow command injection via virtual environment activation scripts. This issue is tracked as CVE-2024-53899 and has been rated with an important security impact by Red Hat Product Security. The vulnerability involves potential command injection, which could be exploited if an attacker can manipulate activation scripts in virtual environments.

References

Community reviews

Loading reviews…