Skip to main content
Report · GCVE DatabaseAbout CVE-2024-0397Published Updated

SUSE · security update for python3.9

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2024-0397· High 7.4

Not known to be exploited · CVSS 7.4 High · fixed in 3.12.3 : patch SUSE soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.12.3, 3.11.9, 3.10.14

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade cpython to 3.12.3, 3.11.9 or 3.10.14.

Affected software

ProductAffectedFixed in
PyPIcpythonpkg:pypi/cpythonOther threatsAffected
  • <3.10.14
  • <3.11.9
  • <3.12.3
  • =3.13.0
Fixed in
  • 3.10.14
  • 3.11.9
  • 3.12.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in CPython versions 3.10.14, 3.11.9, 3.12.3, and 3.13.0a5. Security updates addressing this vulnerability are also available for affected Linux distributions including Red Hat Enterprise Linux 9 and Ubuntu 20.04 LTS and 22.04 LTS. Users should apply these official security updates to remediate the issue. No additional mitigation steps are indicated by the vendor advisories.

Description

A memory race condition vulnerability exists in the Python ssl module affecting the ssl.SSLContext methods cert_store_stats() and get_ca_certs(). This race condition can occur when these methods are called concurrently with certificate loading into the SSLContext, such as during a TLS handshake with a configured certificate directory. The issue may cause applications to obtain incorrect certificate information, potentially leading to SSL-related problems. The vulnerability has been fixed in CPython versions 3.10.14, 3.11.9, 3.12.3, and 3.13.0a5. Security updates are available for various Linux distributions including Red Hat Enterprise Linux and Ubuntu. The CVSS score is 7.4, indicating medium severity.

References

Community reviews

Loading reviews…