Skip to main content
VulnerabilityPublished

CVE-2025-10729: qt5-qtsvg security update

Affects qt5-qtsvgSource GCVE Database

0
Authoritative record:CVE-2025-10729· Critical 9.4

Not known to be exploited · CVSS 9.4 Critical : upgrade to 5.11.1-8.oe2003sp4 as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.11.1-8.oe2003sp4
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/S:P/RE:H/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade qt5-qtsvg to 5.11.1-8.oe2003sp4.

Affected software

ProductAffectedFixed in
openEuler 20.03-LTS-SP4qt5-qtsvgpkg:rpm/openEuler/qt5-qtsvg&distro=openEuler-20.03-LTS-SP4Other threatsAffected
  • <5.11.1-8.oe2003sp4
Fixed in
  • 5.11.1-8.oe2003sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied to affected systems. Red Hat has released patched versions of qt6-qtsvg for Red Hat Enterprise Linux 10 and related products. Users should follow the vendor's official guidance to update to the fixed versions. No additional mitigation steps are indicated by the vendor advisory.

Description

A use-after-free vulnerability (CVE-2025-10729) exists in the Qt SVG module, which handles rendering and displaying SVG images. The flaw occurs when the module parses a <pattern> node not properly nested under a structural node, leading to potential use-after-free conditions. This vulnerability affects multiple versions of qt5-qtsvg and has been rated critical. A security update addressing this issue is available from Red Hat.

References

Community reviews

Loading reviews…