Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.5 Product Release Update
Affects Red Hat ansible-coreSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 5.5 Medium : upgrade the Red Hat redhat/ansible-core package to 2.16.13 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.16.13
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Red Hat redhat/ansible-core package to 2.16.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/ansible-corepkg:rpm/redhat/ansible-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat has released official fixes addressing these vulnerabilities. Users should update ansible-core to version 2.16.13 or later and apply the Red Hat Ansible Automation Platform 2.5 updates including installer version 2.5-5 and automation-gateway 2.5.3-2. Applying these updates will remediate the vulnerabilities. No additional mitigation steps are indicated by the vendor advisory.
Description
Red Hat Ansible Automation Platform 2.5 has security vulnerabilities including exposure of sensitive information in Ansible Vault files due to improper logging (CVE-2024-8775) and unauthorized read/write access by the ansible-core user (CVE-2024-9902). These issues have been addressed in updates to ansible-core and related components. The update to ansible-core version 2.16.13 and other platform components resolves these vulnerabilities.
References
- access.redhat.com/errata/RHSA-2024:9894 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2312119 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2318271 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_9894.json (opens in a new tab)