Skip to main content
CVE-2026-9277VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.1 security update

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-9277· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade Red Hat shell-quote to 1.8.4 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade shell-quote to 1.8.4.

Affected software

ProductAffectedFixed in
shell-quoteAffected
  • >=1.1.0 <1.8.4
Fixed in
  • 1.8.4
npmshell-quotepkg:npm/shell-quoteOther threatsAffected
  • =1.1.0
Fixed in–
npmshell-quotepkg:npm/shell-quoteOther threatsAffected
  • >=1.1.0 <1.8.4
Fixed in
  • 1.8.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The Red Hat advisory does not currently provide a fix or patch for these vulnerabilities in Ansible Automation Platform 2.1. The vm2 library vulnerability is fixed in vm2 version 3.11.0, so upgrading to this or a later version of vm2 would mitigate the issue. No specific mitigations are detailed in the advisory, so users should avoid exposing the sandbox to untrusted code submissions where possible.

Description

Red Hat Ansible Automation Platform 2.1 has a security advisory related to multiple CVEs including CVE-2026-43997, which affects the vm2 Node.js sandbox library. This vulnerability allows sandboxed code to escape isolation by obtaining host objects, enabling arbitrary code execution on the host. The advisory notes that updated images are available with new features and bug fixes, but no explicit fix for these vulnerabilities is currently provided in the advisory.

References

Community reviews

Loading reviews…