Skip to main content
CVE-2025-66566VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Build of Apache Camel 4.10 for Quarkus 3.20 update is now available (RHBQ 3.20.4.SP1)

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2025-66566· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade Red Hat lz4-java to 1.10.1 soon.

Data as of 5 Nov 2026, 20:36 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.10.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade com.github.yawkat/lz4-java to 1.10.1.

Affected software

ProductAffectedFixed in
Mavencom.github.yawkat/lz4-javapkg:maven/com.github.yawkat/lz4-javaOther threatsAffected
  • <1.10.1
Fixed in
  • 1.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an update (RHBQ 3.20.4.SP1) that addresses this vulnerability. Users should apply this update after ensuring all previously released relevant errata have been applied. Detailed update instructions are available from Red Hat. No additional mitigations are indicated or required beyond applying the official fix.

Description

A security update is available for Red Hat Build of Apache Camel 4.10 for Quarkus 3.20 addressing an information disclosure vulnerability in lz4-java (CVE-2025-66566). The flaw involves insufficient clearing of the output buffer in Java-based decompressor implementations, potentially exposing sensitive data. JNI-based implementations are not affected. The vulnerability is rated as important by Red Hat due to the risk of sensitive data exposure.

References

Community reviews

Loading reviews…