Skip to main content
CVE-2025-1247VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Build of Apache Camel 4.8 for Quarkus 3.15 update is now available (RHBQ 3.15.3.SP1)

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-1247· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade Red Hat quarkus-rest to 3.18.2 soon.

Data as of 5 Nov 2026, 13:04 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.18.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade quarkus-rest to 3.18.2.

Affected software

ProductAffectedFixed in
quarkus-restAffected
  • <3.18.2
Fixed in
  • 3.18.2
GitHubquarkus-restpkg:github/quarkus-restOther threatsAffected
  • <3.18.2
Fixed in
  • 3.18.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

An update for Red Hat Build of Apache Camel 4.8 for Quarkus 3.15 update is now available (RHBQ 3.15.3.SP1). The purpose of this text-only errata is to inform you about the enhancements that improve your developer experience and ensure the security and stability of your products: * quarkus-resteasy: Memory Leak in Quarkus RESTEasy Classic When Client Requests Timeout (CVE-2025-1634) * io.quarkus/quarkus-rest: Quarkus REST Endpoint Request Parameter Leakage Due to Shared Instance (CVE-2025-1247) * io.netty/netty-handler: SslHandler doesn't correctly validate packets which can lead to native crash when using native SSLEngine (CVE-2025-24970)

References

Community reviews

Loading reviews…