Skip to main content
CVE-2024-8698VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat build of Keycloak 24.0.8 Update

Affects Red Hat keycloakSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-8698· High 7.7

Not known to be exploited · public detection template (Nuclei) · CVSS 7.7 High : upgrade Red Hat keycloak to 24.0.8 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.0% chance of exploitation in 30 days – higher than 80% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 24.0.8
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Sep 2024

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.keycloak/keycloak to 24.0.8.

Affected software

ProductAffectedFixed in
Mavenorg.keycloak/keycloakpkg:maven/org.keycloak/keycloakOther threatsAffected
  • <24.0.8
Fixed in
  • 24.0.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official fix in version 24.0.8 of the Red Hat build of Keycloak. Users should back up their existing installations, including applications, configuration files, and databases, before applying the update. Applying the update to version 24.0.8 fully mitigates these vulnerabilities.

Description

Red Hat has released a security advisory for the Red Hat build of Keycloak addressing two vulnerabilities: CVE-2024-8698, which involves improper verification of SAML responses that can lead to privilege escalation, and CVE-2024-8883, which concerns vulnerable redirect URI validation resulting in open redirect issues. These vulnerabilities affect authentication and single sign-on capabilities. The advisory recommends updating to version 24.0.8 and backing up existing installations before applying the update.

References

Community reviews

Loading reviews…