Skip to main content
CVE-2025-8419VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat build of Keycloak 26.2.8 Security Update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-8419· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade Red Hat to 26.2.8 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.2.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Red Hat to 26.2.8.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=26.2.0 <26.2.8
Fixed in
  • 26.2.8

AI-suggested

Red Hat has released version 26.2.8 of their build of Keycloak to address these vulnerabilities. Users should back up their existing installations, including applications, configuration files, and databases, before applying the update. Applying this official update is the recommended remediation. No other mitigation steps are specified or required according to the vendor advisory.

Description

Red Hat has released a security update for its build of Keycloak, version 26.2.8, addressing two vulnerabilities: a variable injection into environment variables (CVE-2025-9162) and an SMTP injection vulnerability (CVE-2025-8419). These issues affect versions from 26.2.0 up to but not including 26.2.8. The update is classified as moderate severity. Users are advised to back up their installations before applying the update.

References

Community reviews

Loading reviews…