Skip to main content
CVE-2026-25645VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Enterprise Linux AI 3.4.4 enhancement update

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-25645· Medium 4.4

Not known to be exploited · CVSS 4.4 Medium : upgrade Red Hat requests to 2.33.0 when convenient.

Data as of 5 Nov 2026, 22:50 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.33.0
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade requests to 2.33.0.

Affected software

ProductAffectedFixed in
psfrequestsAffected
  • <2.33.0
Fixed in
  • 2.33.0
PyPIrequestspkg:pypi/requestsOther threatsAffected
  • <2.33.0
Fixed in
  • 2.33.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Currently, no mitigation is available that meets Red Hat's criteria for ease of use, applicability, or stability. The updated container disk images in Red Hat Enterprise Linux AI 3.4.4 do not address this vulnerability. Organizations may consider restricting local access to the temporary directory as a precautionary measure, but no official mitigation is provided.

Description

A vulnerability exists in the requests HTTP library used in Red Hat Enterprise Linux AI, specifically in the extract_zipped_paths() function that loads Certificate Authority (CA) bundles. A local attacker can exploit this by pre-creating a malicious CA bundle file in the system's temporary directory, causing the application to load the malicious file instead of the legitimate one. This can lead to bypassing security controls and compromising integrity. The update provides new container disk images but does not include a fix for this vulnerability.

References

Community reviews

Loading reviews…