Skip to main content
CVE-2026-116591VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Hardened Images RPMs Security Update

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-116591· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade Red Hat to 1.20.2 soon.

Data as of 30 Oct 2026, 01:47 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.7
Patch
Available – fixed in 1.20.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade compress to 1.20.2.

Affected software

ProductAffectedFixed in
klauspostcompressAffected
  • <1.20.2
Fixed in
  • 1.20.2

AI-suggested

Apply the Red Hat security update that includes the fixed grype package version 0.121.0-0.3.hum1. Additionally, reject or filter untrusted Zstandard-compressed payloads at ingress proxies or restrict decompression endpoints to authenticated, trusted clients. There is no direct configuration-level workaround within the library itself.

Description

A vulnerability (CVE-2026-116591) was found in the klauspost compress library's Zstandard (zstd) decompression implementation used in Red Hat Hardened Images RPMs. The flaw is an integer handling error that causes the decompression logic to retain stale internal state and perform an out-of-bounds read, leading to an unhandled panic that crashes the application. This results in a denial of service (DoS) when processing specially crafted compressed streams. The vulnerability affects the grype package versions updated to 0.121.0-0.3.hum1. No direct workaround exists within the library itself, but filtering untrusted inputs or restricting decompression to trusted clients can mitigate the risk.

References

Community reviews

Loading reviews…