Skip to main content
CVE-2026-77214VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Hardened Images RPMs Security Update

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-77214· High 8.3

Not known to be exploited · CVSS 8.3 High.

Data as of 29 Oct 2026, 16:21 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.3
CNA (VulnCheck)CVSS 3.18.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
libexpatlibexpatAffected
  • <=2.8.5
Fixed in–
GitHublibexpatpkg:github/libexpatOther threatsAffected
  • <=2.8.5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated expat packages (expat-2.9.0-1.hum1 and related) that fix this vulnerability. Users of Red Hat Hardened Images RPMs should apply these updates promptly to remediate the issue. No additional mitigations are specified or required beyond applying the official security update.

Description

A heap buffer over-read vulnerability (CVE-2026-77214) was found in the expat XML parser used in Red Hat Hardened Images RPMs. This flaw allows a remote attacker to cause information disclosure or denial of service by exploiting repeated parse buffer operations with unvalidated buffer lengths. The vulnerability can leak adjacent heap memory, potentially aiding in bypassing security mitigations like ASLR. The issue affects multiple architectures and is rated as important due to the widespread use of expat in network-facing services. Red Hat has released updated expat packages to address this issue.

References

Community reviews

Loading reviews…