Skip to main content
CVE-2025-53020VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat JBoss Core Services Apache HTTP Server 2.4.62 SP4 security update

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-53020· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat httpd to 2.4.64 soon.

Data as of 30 Oct 2026, 03:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.64
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade apache/httpd to 2.4.64.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <2.4.64
Fixed in
  • 2.4.64

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available in Red Hat JBoss Core Services Apache HTTP Server 2.4.62 Service Pack 4, which replaces Service Pack 3 and includes fixes for all listed vulnerabilities. Users should apply this update after ensuring all previously released errata relevant to their system have been applied. Refer to the official Red Hat advisory RHSA-2026:27200 and the linked documentation for detailed update instructions. No additional mitigation steps are indicated beyond applying the update.

Description

Red Hat JBoss Core Services Apache HTTP Server 2.4.62 Service Pack 4 includes multiple security fixes addressing vulnerabilities such as arbitrary code execution, remote denial of service via HTTP/2 compression bomb and Slowloris-style attacks, heap-based buffer over-reads, NULL pointer dereferences causing crashes, and resource exhaustion. These vulnerabilities affect various modules including mod_proxy_ajp, mod_http2, mod_authn_socache, mod_dav_lock, mod_md, and nghttp2. The update replaces the previous Service Pack 3 and provides important security improvements.

References

Community reviews

Loading reviews…