Skip to main content
CVE-2024-42516VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat JBoss Core Services Apache HTTP Server 2.4.62 SP5 security update

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-42516· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat httpd to 2.4.64 soon.

Data as of 30 Oct 2026, 03:14 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.64
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade apache/httpd to 2.4.64.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • =2.4.0 <2.4.64
Fixed in
  • 2.4.64

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available in Red Hat JBoss Core Services Apache HTTP Server 2.4.62 Service Pack 5 that addresses all listed vulnerabilities. Users should apply this update promptly after ensuring all previously released relevant errata have been applied. No additional mitigation steps are indicated beyond applying the official update.

Description

Red Hat JBoss Core Services Apache HTTP Server 2.4.62 Service Pack 5 includes multiple security fixes addressing vulnerabilities such as privilege escalation, use-after-free leading to arbitrary code execution or denial of service, denial of service via crafted inputs, SSRF, buffer overflows, cross-site scripting, and information disclosure. These vulnerabilities affect various Apache HTTP Server modules including mod_http2, mod_ldap, mod_proxy, mod_proxy_ftp, mod_proxy_html, mod_xml2enc, mod_headers, mod_mime, and mod_dav_fs. The update replaces the previous Service Pack 4 and aims to provide a more consistent and faster update experience for Red Hat JBoss middleware products.

References

Community reviews

Loading reviews…