Skip to main content
CVE-2025-69873VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Quay 3.14.7

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2025-69873· Low 2.9

Not known to be exploited · CVSS 2.9 Low : upgrade Red Hat to 8.17.2 or 6.14.0 when convenient.

Data as of 5 Nov 2026, 19:19 UTC

CVSS 3.1 base score
2.9Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.17.2, 6.14.0
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade ajv to 8.17.2 or 6.14.0.

Affected software

ProductAffectedFixed in
ajv.jsajvAffected
  • >=7.0.0 <8.17.2
Fixed in
  • 8.17.2
ajv.jsajvAffected
  • <6.14.0
Fixed in
  • 6.14.0

AI-suggested

Red Hat advises disabling the $data option if it is not required by the application. If $data must be used, strict validation of input fields referenced by the pattern keyword should be implemented to ensure only safe characters are accepted. Red Hat Quay 3.14.7 is available with bug fixes, but the advisory does not explicitly confirm a patch for this specific CVE. Users should apply all relevant errata and updates as per Red Hat guidance.

Description

A vulnerability in Red Hat Quay related to the ajv library's $data option allows an attacker to supply a malicious regular expression pattern that triggers a Regular Expression Denial of Service (ReDoS). This causes the application to become unresponsive due to excessive CPU consumption. The issue requires the $data option to be enabled and attacker control over the input pattern. The vulnerability is rated as important severity by Red Hat.

References

Community reviews

Loading reviews…