SUSE · security update for redis
Affects SUSESource GCVE Database
Not known to be exploited · fixed in 7.4.2 : patch SUSE as a priority.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 8.1% chance of exploitation in 30 days – higher than 94% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.4.2, 7.2.8, 7.2.7 +2
Exploitation evidence
Disclosed: evidence found.
CVE published 27 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SUSE Product Security Team SUSE | Affected
| Fixed in
|
AI-suggested
Apply the official patches available in Redis versions 6.2.17, 7.2.7, and 7.4.2 or later to remediate this vulnerability. Until patching is possible, restrict Lua script execution using Access Control List (ACL) rules to prevent exploitation. Follow vendor guidance for applying updates as detailed in the Red Hat advisory.
Description
CVE-2024-46981 is a critical vulnerability in Redis that allows an authenticated user to exploit specially crafted Lua scripts to manipulate the garbage collector, potentially leading to remote code execution. This affects multiple Redis versions prior to 6.2.17, 7.2.7, and 7.4.2. Official patches addressing this vulnerability are available in these versions. As a temporary mitigation, administrators can restrict Lua script execution using ACL rules to prevent exploitation until patching is applied.
References
- access.redhat.com/errata/RHSA-2025:0692 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2336004 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2336007 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_0692.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:0400 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_0400.json (opens in a new tab)
- github.com/redis/redis/releases/tag/6.2.17 (opens in a new tab)
- github.com/redis/redis/releases/tag/7.2.7 (opens in a new tab)
- github.com/redis/redis/releases/tag/7.4.2 (opens in a new tab)
- github.com/redis/redis/security/advisories/GHSA-39h2-x6c4-6w4c (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/01/msg00018.html (opens in a new tab)
- vicarius.io/vsociety/posts/cve-2024-46981-detect-redis-vulnerability (opens in a new tab)
- vicarius.io/vsociety/posts/cve-2024-46981-mitigate-redis-vulnerability (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-46981 (opens in a new tab)
- codeberg.org/redict/redict/releases/tag/7.3.2 (opens in a new tab)
- github.com/valkey-io/valkey/releases/tag/8.0.2 (opens in a new tab)
- redict.io/posts/2025-01-08-redict-7.3.2-released (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2025_0692.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2025-January/000797.html (opens in a new tab)
- suse.com/security/cve/CVE-2024-46981/ (opens in a new tab)
- suse.com/security/cve/CVE-2024-51741/ (opens in a new tab)