Skip to main content
CVE-2025-46817VulnerabilityPublished Updated

SUSE · Security update of valkey

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · public detection template (Nuclei) : upgrade to 7.0.12 as a priority.

Data as of 26 Oct 2026, 07:57 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
3.9% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.12

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jan 2026

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade redhat/redis to 7.0.12.

Affected software

ProductAffectedFixed in
Red Hatredhat/redispkg:rpm/redhat/redisOther threatsAffected
  • <7.0.12
Fixed in
  • 7.0.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update to valkey version 8.0.6 is available and should be applied promptly to remediate these vulnerabilities. The vendor advisory explicitly states that patches have been released and provides guidance on applying the update. No additional mitigation steps are required beyond applying the official fix. Systems running affected versions should upgrade to 8.0.6 or later to ensure protection.

Description

Multiple security vulnerabilities in valkey related to Lua scripting have been fixed in version 8.0.6. These include remote code execution via Lua scripts, integer overflow leading to potential RCE, execution of Lua scripts in another user's context, and out-of-bound read issues. The update also includes various bug fixes unrelated to security. The vulnerabilities are rated critical and patches are available.

References

Community reviews

Loading reviews…