Skip to main content
CVE-2024-47081VulnerabilityPublished Updated

Red Hat Security Advisory: resource-agents security update

Affects Red Hat resource-agentsSource GCVE Database

0
Compare
Authoritative record:CVE-2024-47081· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade Red Hat requests to 2.32.4 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.32.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade requests to 2.32.4.

Affected software

ProductAffectedFixed in
PyPIrequestspkg:pypi/requestsOther threatsAffected
  • <2.32.4
Fixed in
  • 2.32.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated resource-agents packages for Red Hat Enterprise Linux 8.8 variants that address this vulnerability. Users should apply these official updates as described in the Red Hat advisory (RHSA-2025:15616) and the referenced article (https://access.redhat.com/articles/11258) to remediate the issue. No additional mitigation steps are indicated beyond applying the vendor-provided fix.

Description

A security update for the resource-agents packages in Red Hat Enterprise Linux addresses a vulnerability (CVE-2024-47081) related to the requests library leaking .netrc credentials via malicious URLs. The resource-agents provide scripts for high-availability service managers like Pacemaker and RGManager. This vulnerability could expose sensitive credentials if exploited. Red Hat has released updated packages for affected RHEL 8.8 variants to mitigate this issue.

References

Community reviews

Loading reviews…