Skip to main content
CVE-2024-47081VulnerabilityPublished

CVE-2024-47081: psf requests · Insufficiently Protected Credentials

Affects psf requestsSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.32.4 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.32.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade psf requests to 2.32.4.

Affected software

ProductAffectedFixed in
PyPIrequestspkg:pypi/requestsOther threatsAffected
  • <2.32.4
Fixed in
  • 2.32.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade of the Requests library to version 2.32.4 or later is the most effective mitigation. 2. For legacy systems where upgrading is not feasible, explicitly disable .netrc credential usage by setting `trust_env=False` on the Requests Session object to prevent automatic credential inclusion. 3. Audit all codebases and automation scripts to identify usage of Requests with .netrc files and assess exposure to untrusted URLs. 4. Implement strict input validation and sanitization for any URLs processed by applications using Requests to reduce the risk of malicious URL injection. 5. Monitor network traffic for unusual outbound requests that could indicate credential leakage attempts. 6. Rotate any credentials stored in .netrc files that may have been exposed or are suspected to be at risk. 7. Educate developers and DevOps teams about the vulnerability and the importance of secure credential handling and library updates. 8. Consider alternative credential management approaches that do not rely on .netrc files, such as environment variables or secure vaults, to reduce attack surface.

Description

Requests is a HTTP library. Due to a URL parsing issue, Requests releases prior to 2.32.4 may leak .netrc credentials to third parties for specific maliciously-crafted URLs. Users should upgrade to version 2.32.4 to receive a fix. For older versions of Requests, use of the .netrc file can be disabled with `trust_env=False` on one's Requests Session.

References

Community reviews

Loading reviews…