Skip to main content
CVE-2024-21536VulnerabilityPublished Updated

Red Hat Security Advisory: RHACS 4.7 security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 4.7.2 soon.

Data as of 25 Oct 2026, 22:09 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.7.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Red Hat to 4.7.2.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=4.7.0 <4.7.2
  • Red Hat
  • Red Hat Advanced Cluster Security for Kubernetes
  • RHACS 4.7 for RHEL 8
  • s390x
  • advanced-cluster-security/rhacs-central-db-rhel8@sha256:69dbfbae6a11cb3d8c7e015f59b22519fb7676a855ff22327639da9f76dffb2c_s390x
Fixed in
  • 4.7.2

AI-suggested

Users running RHACS 4.7 versions earlier than 4.7.2 should upgrade to version 4.7.2, which includes fixes for these vulnerabilities. No additional mitigation steps are indicated by the vendor advisory.

Description

This release of RHACS 4.7.2 includes the following security fixes: * CVE-2024-21536: Denial of Service vulnerability in the `http-proxy-middleware` package. * CVE-2025-30204: Excessive memory allocation during header parsing in `golang-jwt` package. * CVE-2024-57083: Denial of Service vulnerability in the `redoc` package. For more details about the security issue(s), including the impact, a CVSS score, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…