Skip to main content
CVE-2025-27219VulnerabilityPublished Updated

SUSE · security update for ruby

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-27219· Medium 5.8

Not known to be exploited · CVSS 5.8 Medium : upgrade the Red Hat redhat/ruby package to 9.6 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/ruby package to 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/rubypkg:rpm/redhat/rubyOther threatsAffected
  • =9.0.0
  • <9.6
  • >=9.6
  • <=9.8
Fixed in
  • 9.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available from Red Hat addressing these vulnerabilities in Ruby. Users should apply the updated Ruby packages as described in Red Hat Advisory RHSA-2025:4487 and the associated article https://access.redhat.com/articles/11258. Applying this update remediates the vulnerabilities. No additional mitigation actions are specified by the vendor.

Description

Two security vulnerabilities were identified in Ruby's CGI module: a Regular Expression Denial of Service (ReDoS) in CGI::Util#escapeElement (CVE-2025-27220) and a Denial of Service in CGI::Cookie.parse (CVE-2025-27219). These issues could allow an attacker to cause denial of service conditions. Red Hat has released security updates addressing these vulnerabilities in Ruby packages for Red Hat Enterprise Linux 9 and related products. The update is rated as having moderate security impact. Users of affected Red Hat Enterprise Linux 9 versions should apply the provided patches to remediate these issues.

References

Community reviews

Loading reviews…