Skip to main content
CVE-2026-42246VulnerabilityPublished Updated

Red Hat Security Advisory: ruby security update

Affects Red Hat rubySource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-42246· High 7.6

Not known to be exploited · CVSS 7.6 High · fixed in Red Hat package updates : patch Red Hat ruby soon.

Data as of 6 Nov 2026, 02:03 UTC

CVSS 4.0 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.6.4, 0.5.14, 0.4.24 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade net-imap to 0.6.4, 0.5.14, 0.4.24 or 0.3.10.

Affected software

ProductAffectedFixed in
rubynet-imapAffected
  • >=0.6.0 <0.6.4
Fixed in
  • 0.6.4
rubynet-imapAffected
  • >=0.5.0 <0.5.14
Fixed in
  • 0.5.14
rubynet-imapAffected
  • >=0.4.0 <0.4.24
Fixed in
  • 0.4.24
rubynet-imapAffected
  • <0.3.10
Fixed in
  • 0.3.10

AI-suggested

Red Hat has released updated Ruby packages for affected Red Hat Enterprise Linux 9.4 variants that fix these vulnerabilities. Users should apply the updates provided in advisory RHSA-2026:33630 as soon as possible. Details on applying the update are available at https://access.redhat.com/articles/11258. No additional mitigations or workarounds are specified in the advisory.

Description

Red Hat has issued a security advisory for Ruby addressing two vulnerabilities in the Net::IMAP library. The first vulnerability (CVE-2026-42258) involves IMAP command injection via symbol arguments. The second vulnerability (CVE-2026-42246) allows information disclosure by bypassing TLS through a man-in-the-middle attack. These issues affect Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions and related variants. The update is rated as important by Red Hat Product Security.

References

Community reviews

Loading reviews…