Skip to main content
CVE-2026-42245VulnerabilityPublished Updated

Red Hat Security Advisory: ruby:3.3 security update

Affects Red Hat ruby:3.3Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-42245· Low 2.3

Not known to be exploited · CVSS 2.3 Low · fixed in Red Hat package updates : update Red Hat net-imap when convenient.

Data as of 6 Nov 2026, 02:03 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.6.4, 0.5.14, 0.4.24
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade net-imap to 0.6.4, 0.5.14 or 0.4.24; net-imap to 0.4.24.

Affected software

ProductAffectedFixed in
rubynet-imapAffected
  • >=0.6.0 <0.6.4
Fixed in
  • 0.6.4
rubynet-imapAffected
  • >=0.5.0 <0.5.14
Fixed in
  • 0.5.14
rubynet-imapAffected
  • <0.4.24
Fixed in
  • 0.4.24
RubyGemsnet-imappkg:gem/net-imapOther threatsAffected
  • <0.4.24
Fixed in
  • 0.4.24

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated packages for the Ruby 3.3 module in Red Hat Enterprise Linux 9.4 that address these vulnerabilities. Users should apply the security update as described in the Red Hat advisory (RHSA-2026:36099) and the referenced article (https://access.redhat.com/articles/11258) to remediate these issues. No additional mitigation steps are indicated beyond applying the official update.

Description

Multiple security vulnerabilities affecting the Ruby 3.3 module in Red Hat Enterprise Linux 9.4 have been addressed. These include a denial of service via crafted IMAP responses, IMAP command injection through symbol arguments, and information disclosure via man-in-the-middle attacks bypassing TLS. The update is rated as important by Red Hat Product Security and applies to various Red Hat Enterprise Linux 9.4 variants.

References

Community reviews

Loading reviews…