Skip to main content
CVE-2026-42246VulnerabilityPublished Updated

Red Hat Security Advisory: ruby:2.5 security update

Affects Red Hat ruby:2.5Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-42246· High 7.6

Not known to be exploited · CVSS 7.6 High · fixed in Red Hat package updates : patch Red Hat ruby:2.5 soon.

Data as of 6 Nov 2026, 02:03 UTC

CVSS 4.0 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.6.4, 0.5.14, 0.4.24 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade net-imap to 0.6.4, 0.5.14, 0.4.24 or 0.3.10.

Affected software

ProductAffectedFixed in
rubynet-imapAffected
  • >=0.6.0 <0.6.4
Fixed in
  • 0.6.4
rubynet-imapAffected
  • >=0.5.0 <0.5.14
Fixed in
  • 0.5.14
rubynet-imapAffected
  • >=0.4.0 <0.4.24
Fixed in
  • 0.4.24
rubynet-imapAffected
  • <0.3.10
Fixed in
  • 0.3.10

AI-suggested

Red Hat has released updated Ruby 2.5 packages for Red Hat Enterprise Linux 8.4 that address these vulnerabilities. Users should apply the security update as described in Red Hat advisory RHSA-2026:35866 and the referenced update article (https://access.redhat.com/articles/11258). No additional mitigation steps are indicated beyond applying the official patches.

Description

Two security vulnerabilities affecting Ruby's Net::IMAP library have been addressed in a Red Hat Enterprise Linux 8.4 update. The first is an IMAP command injection vulnerability via symbol arguments (CVE-2026-42258). The second is an information disclosure vulnerability that allows a man-in-the-middle attack to bypass TLS protections (CVE-2026-42246). These issues have been rated with an important security impact by Red Hat Product Security.

References

Community reviews

Loading reviews…