Skip to main content
CVE-2024-39908VulnerabilityPublished Updated

Red Hat Security Advisory: ruby:3.1 security update

Affects Red Hat ruby:3.1Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-39908· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium : upgrade Red Hat rexml to 3.3.2 when convenient.

Data as of 2 Nov 2026, 02:44 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.14.3
Patch
Available – fixed in 3.3.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade rexml to 3.3.2.

Affected software

ProductAffectedFixed in
RubyGemsrexmlpkg:gem/rexmlOther threatsAffected
  • <3.3.2
Fixed in
  • 3.3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an updated Ruby 3.1 module for Red Hat Enterprise Linux 8 that includes fixes for all listed vulnerabilities. Users should apply the security update as described in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate these issues. No alternative mitigations or workarounds are specified.

Description

Multiple denial of service (DoS) vulnerabilities and a userinfo leakage issue have been identified in Ruby 3.1 components, including REXML, CGI, and URI modules. These vulnerabilities could allow attackers to cause service disruption or leak sensitive user information when processing specially crafted inputs. Red Hat has issued a security update for Ruby 3.1 on Red Hat Enterprise Linux 8 to address these issues.

References

Community reviews

Loading reviews…