Skip to main content
CVE-2024-56337VulnerabilityPublished Updated

Red Hat Security Advisory: tomcat security update

Affects Red Hat tomcatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-56337· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical.

Data as of 5 Nov 2026, 14:33 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.19.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threatsAffected
  • >=8.5.0 <=8.5.100
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated Tomcat packages that address these vulnerabilities. Users should apply the security update for Tomcat version 9.0.87-1.el8_8.5 or later as provided in Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions and Telecommunications Update Service. Detailed update instructions are available at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official update.

Description

Red Hat has issued a security advisory for Apache Tomcat addressing two vulnerabilities: an incomplete fix for a remote code execution (RCE) vulnerability due to a time-of-check to time-of-use (TOCTOU) issue in JSP compilation (CVE-2024-56337), and a denial of service (DoS) vulnerability via malformed HTTP/2 PRIORITY_UPDATE frames (CVE-2025-31650). The advisory rates the security impact as Important and provides updated packages for Red Hat Enterprise Linux 8.8 variants. Users are advised to apply the provided updates to remediate these issues.

References

Community reviews

Loading reviews…