CVE-2025-27151: redis-check-aof may lead to stack overflow and potential RCE
Affects redisSource GCVE Database
Not known to be exploited · CVSS 4.7 Medium : upgrade to 10.3 or 10.2 when convenient.
Data as of 26 Oct 2026, 07:57 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.3, 10.2
Exploitation evidence
Disclosed: evidence found.
CVE published 29 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade redhat/valkey to 10.3 or 10.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/valkeypkg:rpm/redhat/valkeyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available and has been released in Redis version 8.0.2. Users should upgrade to version 8.0.2 or later to remediate this vulnerability. Red Hat has provided updated valkey packages for Red Hat Enterprise Linux 10 and related distributions; applying these updates will mitigate the issue. No additional mitigation steps are required beyond applying the official updates.
Description
A stack-based buffer overflow vulnerability exists in redis-check-aof component of Valkey (an advanced key-value store) in versions from 7.0.0 up to but not including 8.0.2. The flaw arises from unsafe use of memcpy with strlen(filepath) on a user-supplied file path, allowing potential stack overflow and code execution. This vulnerability is identified as CVE-2025-27151 and has been patched in version 8.0.2. Red Hat has issued an important security advisory with updates available for affected Red Hat Enterprise Linux 10 variants.
References
- access.redhat.com/errata/RHSA-2025:11401 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2369153 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2376857 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2376858 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_11401.json (opens in a new tab)
- github.com/redis/redis/commit/643b5db235cb82508e72f11c7b4bbfc7dc39be56 (opens in a new tab)
- github.com/redis/redis/releases/tag/8.0.2 (opens in a new tab)
- github.com/redis/redis/security/advisories/GHSA-5453-q98w-cmvm (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-27151 (opens in a new tab)