Skip to main content
CVE-2025-53905VulnerabilityPublished Updated

Red Hat Security Advisory: vim security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 10.2.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Red Hat to 10.2.0.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=10.0 <10.2.0
Fixed in
  • 10.2.0

AI-suggested

Red Hat has released updated Vim packages that address these path traversal vulnerabilities. Users running affected versions of Red Hat Enterprise Linux 10 should apply the security update as detailed in Red Hat advisory RHSA-2025:17913 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor.

Description

Two path traversal vulnerabilities (CVE-2025-53905 and CVE-2025-53906) have been identified in Vim, the improved vi editor, affecting Red Hat Enterprise Linux 10. These vulnerabilities could allow an attacker to access files or directories outside the intended scope. Red Hat has released security updates addressing these issues with a moderate severity rating. The update is available for multiple architectures and variants of Red Hat Enterprise Linux 10. Users are advised to apply the provided updates to mitigate the risk.

Reports on CVE-2025-53905

References

Community reviews

Loading reviews…