Red Hat Security Advisory: virt:rhel and virt-devel:rhel security update
Affects Red HatSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited : upgrade Red Hat to 8.10.0 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.10.0
Exploitation evidence
Disclosed: evidence found.
CVE published 24 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Red Hat to 8.10.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Red Hat Product Security Red Hat | Affected
| Fixed in
|
AI-suggested
Red Hat has released an official security update for the virt:rhel and virt-devel:rhel modules that addresses these vulnerabilities. Users should apply the update as described in the Red Hat advisory RHSA-2024:6964 and the referenced article https://access.redhat.com/articles/11258. This update fixes the double free, denial of service, and certificate validation issues. No additional mitigation steps are required beyond applying the official patch.
Description
Red Hat has issued a moderate security update for the virt:rhel and virt-devel:rhel modules in Red Hat Enterprise Linux 8. The update addresses three vulnerabilities: a double free vulnerability due to a DMA reentrancy issue in QEMU virtio (CVE-2024-3446), a denial of service caused by improper synchronization in the QEMU NBD server during socket closure (CVE-2024-7409), and improper certificate validation in the libnbd NBD server (CVE-2024-7383). These vulnerabilities affect user-space components used to run and manage virtual machines with KVM. The update is available for Red Hat Enterprise Linux 8 versions from 8.0.0 up to but not including 8.10.0 across multiple architectures including s390x. No known exploits in the wild have been reported. Users should apply the official Red Hat update to remediate these issues.
References
- access.redhat.com/errata/RHSA-2024:6964 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2274211 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2302487 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2302865 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_6964.json (opens in a new tab)