Skip to main content
CVE-2024-44192VulnerabilityPublished Updated

SUSE webkit2gtk3 · security update for webkit2gtk3

Affects SUSE webkit2gtk3Source GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-44192· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade the Red Hat redhat/webkit2gtk3 package to 9.8 or 9.6 when convenient.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/webkit2gtk3 package to 9.8 or 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/webkit2gtk3pkg:rpm/redhat/webkit2gtk3Other threatsAffected
  • >=9.0.0 <9.6
  • >=9.6 <9.8
Fixed in
  • 9.6
  • 9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An important security update for webkit2gtk3 is available from Red Hat and should be applied promptly to affected systems. The vendor advisory (RHSA-2025:7387) provides detailed instructions on how to apply the update. Users should follow the official Red Hat guidance to remediate these vulnerabilities. No additional mitigation steps are indicated beyond applying the provided patches.

Description

Multiple security vulnerabilities have been identified in WebKitGTK, the GTK port of the WebKit web rendering engine, affecting Red Hat Enterprise Linux 9. These vulnerabilities include issues that may cause unexpected process crashes, denial-of-service conditions, cross-site scripting attacks, and cross-origin data exfiltration. An important security update is available from Red Hat to address these issues. Users of affected Red Hat Enterprise Linux 9 variants should apply the update to mitigate these risks.

References

Community reviews

Loading reviews…