Skip to main content
CVE-2026-95387VulnerabilityPublished

Red Hat Security Advisory: wireshark security update

Affects Red Hat wiresharkSource GCVE Database

0
Compare
Authoritative record:CVE-2026-95387· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade Red Hat wireshark to 4.6.9 or 4.4.19 soon.

Data as of 2 Nov 2026, 13:31 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.9, 4.4.19
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Wireshark and wireshark/wireshark to 4.6.9 or 4.4.19.

Affected software

ProductAffectedFixed in
Wireshark FoundationWiresharkAffected
  • >=4.6.0 <4.6.9
Fixed in
  • 4.6.9
Wireshark FoundationWiresharkAffected
  • >=4.4.0 <4.4.19
Fixed in
  • 4.4.19
GitHubwireshark/wiresharkpkg:github/wireshark/wiresharkOther threatsAffected
  • >=4.4.0 <4.4.19
  • >=4.6.0 <4.6.9
Fixed in
  • 4.4.19
  • 4.6.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated Wireshark packages that fix this vulnerability. Users should apply the security update available for Red Hat Enterprise Linux 8 and related CodeReady Linux Builder products as described in the Red Hat advisory RHSA-2026:93627. The vendor provides detailed instructions for applying the update at https://access.redhat.com/articles/11258. No additional mitigation steps are required beyond applying the official patch.

Description

A heap-based buffer overflow vulnerability exists in the SPDY dissector of Wireshark, a network protocol analyzer. This flaw can lead to a denial of service condition. Red Hat has issued a security update addressing this vulnerability in Wireshark packages for Red Hat Enterprise Linux 8 and related products.

References

Community reviews

Loading reviews…