Skip to main content
CVE-2026-117536VulnerabilityPublished

REDAXO before 5.21.3 contains a cross-site request forgery vulnerability in the backend user administration page

Source GCVE Database

0
Authoritative record:CVE-2026-117536· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 5.21.3 soon.

Data as of 27 Oct 2026, 13:26 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.21.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade core and redaxo/core to 5.21.3.

Affected software

ProductAffectedFixed in
redaxocoreAffected
  • <5.21.3
Fixed in
  • 5.21.3
GitHubredaxo/corepkg:github/redaxo/coreOther threatsAffected
  • <5.21.3
Fixed in
  • 5.21.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in REDAXO version 5.21.3 which corrects the CSRF token validation logic. Users should upgrade to version 5.21.3 or later to remediate this vulnerability. No other mitigation guidance is provided or necessary as the issue is addressed by the official patch.

Description

REDAXO versions before 5.21.3 have a cross-site request forgery (CSRF) vulnerability in the backend user administration page. The CSRF token check is only enforced when the save parameter is set, but the update path triggered by FUNC_UPDATE bypasses this check. This allows attackers to trick logged-in backend users with the users[] permission into performing unauthorized actions such as granting administrator rights, deactivating accounts, or locking out the sole administrator via crafted GET requests.

References

Community reviews

Loading reviews…