REDAXO before 5.21.5 contains a cross-site request forgery vulnerability because the backend processes the safemode
Source GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 5.21.5 when convenient.
Data as of 27 Oct 2026, 13:27 UTC
- Patch
- Available – fixed in 5.21.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade core and redaxo/core to 5.21.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| redaxocore | Affected
| Fixed in
|
GitHubredaxo/corepkg:github/redaxo/coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 5.21.5 or later is implied but not explicitly stated in the input. Until patched, administrators should avoid clicking untrusted links while logged in and consider additional CSRF protections or access restrictions.
Description
REDAXO versions before 5.21.5 have a cross-site request forgery (CSRF) vulnerability in the backend. The vulnerability arises because the safemode GET parameter in index.php is processed without validating a CSRF token. An attacker can exploit this by tricking a logged-in administrator into clicking a crafted link, which can disable global safe mode or enable session safe mode, potentially impacting backend addon functionality.