REDAXO before 5.21.3 contains a reflected cross-site scripting vulnerability in the backend media pool detail page
Source GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 5.21.3 when convenient.
Data as of 27 Oct 2026, 13:15 UTC
- Patch
- Available – fixed in 5.21.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade core and redaxo/core to 5.21.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| redaxocore | Affected
| Fixed in
|
GitHubredaxo/corepkg:github/redaxo/coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in REDAXO version 5.21.3. Users should upgrade to version 5.21.3 or later to remediate this vulnerability. Until then, avoid clicking untrusted links in the backend media pool detail page and restrict backend access to trusted users.
Description
REDAXO versions prior to 5.21.3 have a reflected cross-site scripting (XSS) vulnerability in the backend media pool detail page. The vulnerability arises because the opener_link parameter is rendered without proper HTML escaping. An unauthenticated attacker can trick logged-in backend users with media permissions into clicking a crafted link, allowing script injection. This script can read the victim's CSRF token and perform actions with their permissions, including potentially executing code via template or module edits if the victim has administrator privileges.