Skip to main content
CVE-2026-66755VulnerabilityPublished Updated

Apache Software Foundation Apache Tika · Relative Path Traversal

Affects tikaSource GCVE Database

0
Compare
Authoritative record:CVE-2026-66755· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium · fixed in 1.22-1ubuntu0.1~esm3 : update tika when convenient.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.22-1ubuntu0.1~esm3, 1.22-2+deb11u1ubuntu0.1~esm2
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/AU:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu tika to 1.22-1ubuntu0.1~esm3 (package) or 1.22-2+deb11u1ubuntu0.1~esm2 (package).

Affected software

ProductAffectedFixed in
Ubuntu Pro 20.04 LTStikapkg:deb/ubuntu/tika?arch=source&distro=esm-apps/focalOther threatsAffected
  • <1.22-1ubuntu0.1~esm3
Fixed in
  • 1.22-1ubuntu0.1~esm3
Ubuntu Pro 22.04 LTStikapkg:deb/ubuntu/tika?arch=source&distro=esm-apps/jammyOther threatsAffected
  • <1.22-2+deb11u1ubuntu0.1~esm2
  • =1.22-2ubuntu0.22.04.1~esm1
Fixed in
  • 1.22-2+deb11u1ubuntu0.1~esm2
Ubuntu 24.04 LTStikapkg:deb/ubuntu/tika?arch=source&distro=nobleOther threatsAffected
  • =1.22-2
Fixed in–
Ubuntu 26.10tikapkg:deb/ubuntu/tika?arch=source&distro=stonkingOther threatsAffected
  • =1.22-2
Fixed in–
Ubuntu 26.04 LTStikapkg:deb/ubuntu/tika?arch=source&distro=resoluteOther threatsAffected
  • =1.22-2
Fixed in–
Mavenorg.apache.tika/tika-corepkg:maven/org.apache.tika/tika-coreOther threatsAffected
  • >=1.8 <=3.3.1
  • =4.0.0-alpha
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Tika to version 3.3.2 or later, or to 4.0.0-beta-1 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Patch status is confirmed fixed in these versions.

Description

Relative Path Traversal in the ISA-Tab parser in Apache Software Foundation Apache Tika from 1.8 through 3.3.1, and 4.0.0-alpha-1, allows an attacker who can place files in a directory that the application subsequently parses to read arbitrary files accessible to the Tika process and have their contents emitted into the extracted text output, via a "Study Assay File Name" value in the ISA-Tab investigation file that traverses outside the dataset directory. Users are recommended to upgrade to version 3.3.2 or 4.0.0-beta-1, which fixes this issue.

References

Community reviews

Loading reviews…