Apache bRPC (version · Resource Exhaustion
Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.18.0 soon.
Data as of 30 Oct 2026, 21:05 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache bRPC and apache/brpc to 1.18.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache bRPCapache/brpc | Affected
| Fixed in
|
GitHubapache/brpcpkg:github/apache/brpcOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache bRPC to version 1.18.0, which contains fixes enforcing limits on decompressed sizes, message lengths, and declared counts to prevent resource exhaustion. Alternatively, apply the patch available at https://github.com/apache/brpc/pull/3476. After applying the fix, requests exceeding the new configured limits are rejected. Operators requiring larger limits can adjust the flags -max_decompressed_body_size and max_body_size accordingly. No other mitigation is indicated.
Description
Apache bRPC versions prior to 1.18.0 contain multiple resource exhaustion vulnerabilities in parsers handling wire-controlled input. These parsers do not enforce limits on client-declared sizes or decompressed output, allowing attackers to cause excessive memory consumption and crash the service process. The issue affects gzip/zlib/snappy decompressors, AMF string readers, RTMP chunk headers, sofa-pbrpc parser, and mcpack2pb message handling. The vulnerability is fixed in version 1.18.0, which enforces size limits and rejects requests exceeding configured thresholds.