Robots::Validate versions from 0.4.3 before 0.4.10 for Perl report clients as imposter robots when User-Agent matcher
Source GCVE Database
Not known to be exploited · CVSS 7.3 High : upgrade to 0.4.10 soon.
Data as of 30 Oct 2026, 20:25 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.3 |
|---|
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.4.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Robots-Validate (Perl module) to 0.4.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Robots-Validate | Affected
| Fixed in
|
CPANRobots-Validatepkg:cpan/Robots-ValidateOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should consider disabling or replacing Robots::Validate or implementing additional validation logic to avoid false positives caused by User-Agent matcher state carryover.
Description
Robots::Validate versions from 0.4.3 up to but not including 0.4.10 for Perl incorrectly identify legitimate clients as imposter robots due to a User-Agent matcher state carryover issue. This occurs because the internal Aho-Corasick search machine does not reset its state between User-Agent checks, allowing a partial match from one User-Agent to affect the next. This flaw can cause legitimate visitors to be blocked if their User-Agent string overlaps with a robot name suffix. The issue also affects deployments using Algorithm::AhoCorasick::XS due to a separate bug preventing its use.
References
- nvd.nist.gov/vuln/detail/CVE-2026-112921 (opens in a new tab)
- github.com/robrwo/Robots-Validate/commit/776a1456e6605492b7582ed25d3d5006ef384402.patch (opens in a new tab)
- metacpan.org/release/RRWO/Robots-Validate-v0.4.10/changes (opens in a new tab)
- metacpan.org/release/RRWO/Robots-Validate-v0.4.11/changes (opens in a new tab)
- openwall.com/lists/oss-security/2026/10/21/30 (opens in a new tab)