Skip to main content
VulnerabilityPublished

CVE-2026-103242: rpm security update

Affects rpmSource GCVE Database

0
Compare
Authoritative record:CVE-2026-103242· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 4.17.0-54.oe2203sp4 soon.

Data as of 4 Nov 2026, 16:58 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.17.0-54.oe2203sp4
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade rpm to 4.17.0-54.oe2203sp4.

Affected software

ProductAffectedFixed in
openEuler 22.03-LTS-SP4rpmpkg:rpm/openEuler/rpm&distro=openEuler-22.03-LTS-SP4Other threatsAffected
  • <4.17.0-54.oe2203sp4
Fixed in
  • 4.17.0-54.oe2203sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security update by upgrading rpm to version 4.17.0-54.oe2203sp4 or later. This update addresses the heap-based buffer overflow vulnerability. No other mitigation steps are indicated by the vendor advisory.

Description

A heap-based buffer overflow vulnerability exists in the RPM Package Manager (rpm) due to improper handling of the RPMTAG_FILESIGNATURES header type in crafted, unsigned RPM packages. This flaw allows an attacker to cause a buffer overflow when the hex2binv() function allocates an insufficient buffer and writes attacker-controlled data beyond its bounds. The vulnerability can be triggered using rpm2cpio, rpm2archive, or rpm -qlvp commands on a malicious package. A fix is available in version 4.17.0-54.oe2203sp4.

References

Community reviews

Loading reviews…