Ruby rack: From versions 3.0.0.beta1 to before 3.1.21, and 3.2.0 to before 3.2.6
Affects ruby-rackSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 3.1.16-0.1ubuntu0.3 soon.
Data as of 3 Nov 2026, 23:20 UTC
- Patch
- Available – fixed in 3.1.16-0.1ubuntu0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu ruby-rack package to 3.1.16-0.1ubuntu0.3.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10ruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and has been released in Ruby Rack versions 3.1.21 and 3.2.6. Users should update to these or later versions to remediate the vulnerability. For Ubuntu users, updated ruby-rack packages are available as per Ubuntu Security Notice USN-8182-1. After updating, restart any applications using Rack to apply the fix. No additional mitigation actions are required beyond applying the official patches.
Description
A denial of service vulnerability exists in the Ruby Rack web server interface in versions from 3.0.0.beta1 to before 3.1.21, and 3.2.0 to before 3.2.6. The vulnerability arises from inefficient parsing of multipart form-data parameters with heavy escaping, causing excessive CPU consumption. This can be triggered by an unauthenticated attacker sending crafted multipart/form-data requests. The issue has been patched in versions 3.1.21 and 3.2.6.