Skip to main content
VulnerabilityPublished Updated

CVE-2026-34829: Ruby rack · Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Multipart::Parser only wraps the

Affects ruby-rackSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 2.1.4-5ubuntu1.2+esm3 : patch ruby-rack soon.

Data as of 3 Nov 2026, 23:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.1.4-5ubuntu1.2+esm3, 2.2.7-1ubuntu0.7, 3.1.16-0.1ubuntu0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu ruby-rack to 2.1.4-5ubuntu1.2+esm3 (package) or 2.2.7-1ubuntu0.7 (package) or 3.1.16-0.1ubuntu0.3 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=resoluteOther threatsAffected
  • 3.1.16-0.1 – 3.2.4-1ubuntu1.1
5 affected builds
Fixed in–
Ubuntu 25.10ruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=questingOther threatsAffected
  • <3.1.16-0.1ubuntu0.3
Fixed in
  • 3.1.16-0.1ubuntu0.3
Ubuntu 24.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=nobleOther threatsAffected
  • <2.2.7-1ubuntu0.7
Fixed in
  • 2.2.7-1ubuntu0.7
Ubuntu Pro 22.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 2.1.4-5ubuntu1+esm2 – 2.1.4-5ubuntu1+esm5
  • <2.1.4-5ubuntu1.2+esm3
4 affected builds
Fixed in
  • 2.1.4-5ubuntu1.2+esm3
Ubuntu Pro 18.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 1.6.4-4 – 1.6.4-4ubuntu0.2+esm10
12 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/xenialOther threatsAffected
  • 1.5.2-4 – 1.6.4-3ubuntu0.2+esm10
14 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading Ruby Rack to versions 2.2.23, 3.1.21, or 3.2.6 or later as provided by your distribution's security updates. For Ubuntu users, update to the package versions listed in USN-8182-1 and restart any Rack applications to apply the fix. No additional mitigation is required once patched.

Description

A vulnerability in Ruby Rack prior to versions 2.2.23, 3.1.21, and 3.2.6 allows an unauthenticated attacker to cause a denial of service by sending a multipart/form-data request without a Content-Length header. This leads to unbounded disk space consumption due to the multipart parser writing uploaded files directly to disk without size limits. The issue has been patched in the stated versions.

References

Community reviews

Loading reviews…