CVE-2026-27601: Ruby rails assets underscore · Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion
Affects ruby-rails-assets-underscoreSource GCVE Database
Not known to be exploited · CVSS 8.2 High · fixed in 1.13.8 : patch ruby-rails-assets-underscore soon.
Data as of 27 Oct 2026, 06:42 UTC
- Patch
- Available – fixed in 1.13.8
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSruby-rails-assets-underscorepkg:deb/ubuntu/ruby-rails-assets-underscore?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSruby-rails-assets-underscorepkg:deb/ubuntu/ruby-rails-assets-underscore?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSruby-rails-assets-underscorepkg:deb/ubuntu/ruby-rails-assets-underscore?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSruby-rails-assets-underscorepkg:deb/ubuntu/ruby-rails-assets-underscore?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.
References
- ubuntu.com/security/CVE-2026-27601 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-27601 (opens in a new tab)
- github.com/jashkenas/underscore/commit/411e222eb0ca5d570cc4f6315c02c05b830ed2b4 (opens in a new tab)
- github.com/jashkenas/underscore/commit/a6e23ae9647461ec33ad9f92a2ecfc220eea0a84 (opens in a new tab)
- github.com/jashkenas/underscore/security/advisories/GHSA-qpx9-hpmf-5gmw (opens in a new tab)