CVE-2026-27601: jashkenas underscore · Unthrottled Resource Allocation
Affects jashkenas underscoreSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 1.13.8 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.13.8
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade jashkenas underscore to 1.13.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jashkenasunderscore | Affected
| Fixed in
|
npmunderscorepkg:npm/underscoreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-27601, organizations should upgrade underscore.js to version 1.13.8 or later, where the vulnerability is fixed. If immediate upgrade is not feasible, developers should implement strict input validation and sanitization to prevent deeply nested or recursive data structures from untrusted sources. Specifically, limit the depth of JSON parsing or reject inputs exceeding a safe nesting threshold. When using _.flatten, always provide a finite depth limit as the second argument to prevent unbounded recursion. For _.isEqual, avoid comparing two distinct data structures derived from untrusted input without prior validation or normalization. Implement robust exception handling around calls to _.flatten and _.isEqual to gracefully catch and manage potential stack overflow errors. Additionally, consider employing runtime monitoring and rate limiting on endpoints processing complex JSON data to detect and block suspicious activity indicative of DoS attempts. Conduct thorough code reviews to identify and refactor any code paths that may inadvertently compare or flatten untrusted recursive data structures. Finally, maintain up-to-date dependency management practices and monitor vulnerability advisories to promptly apply security patches.
Description
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.