Skip to main content
VulnerabilityPublished Updated

CVE-2025-61594: ruby2.3, ruby2.5, ruby2.7, ruby3.0, ruby3.2, ruby3.3 vulnerability

Affects ruby2.3Source GCVE Database

0
Authoritative record:CVE-2025-61594· Low 2.1

Not known to be exploited · CVSS 2.1 Low · fixed in 2.3.1-2~ubuntu16.04.16+esm12 : update ruby2.3 when convenient.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.3.1-2~ubuntu16.04.16+esm12, 2.5.1-1ubuntu1.16+esm7, 2.7.0-5ubuntu1.18+esm4 +3
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10ruby3.3pkg:deb/ubuntu/ruby3.3?arch=source&distro=questingOther threatsAffected
  • <3.3.8-2ubuntu2.1
Fixed in
  • 3.3.8-2ubuntu2.1
Ubuntu 24.04 LTSruby3.2pkg:deb/ubuntu/ruby3.2?arch=source&distro=nobleOther threatsAffected
  • <3.2.3-1ubuntu0.24.04.7
Fixed in
  • 3.2.3-1ubuntu0.24.04.7
Ubuntu 22.04 LTSruby3.0pkg:deb/ubuntu/ruby3.0?arch=source&distro=jammyOther threatsAffected
  • <3.0.2-7ubuntu2.12
Fixed in
  • 3.0.2-7ubuntu2.12
Ubuntu Pro 20.04 LTSruby2.7pkg:deb/ubuntu/ruby2.7?arch=source&distro=esm-infra/focalOther threatsAffected
  • <2.7.0-5ubuntu1.18+esm4
Fixed in
  • 2.7.0-5ubuntu1.18+esm4
Ubuntu Pro 18.04 LTSruby2.5pkg:deb/ubuntu/ruby2.5?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <2.5.1-1ubuntu1.16+esm7
Fixed in
  • 2.5.1-1ubuntu1.16+esm7
Ubuntu Pro 16.04 LTSruby2.3pkg:deb/ubuntu/ruby2.3?arch=source&distro=esm-infra/xenialOther threatsAffected
  • <2.3.1-2~ubuntu16.04.16+esm12
Fixed in
  • 2.3.1-2~ubuntu16.04.16+esm12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

It was discovered that the Ruby URI gem did not properly handle sensitive information when combining URIs. A remote attacker could possibly use this issue to leak authentication credentials.

References

Community reviews

Loading reviews…