Skip to main content
CVE-2025-61594VulnerabilityPublished Updated

CVE-2025-61594: ruby uri · Information Exposure

Affects ruby uriSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 2.1 High : upgrade to 0.12.5 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
2.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.12.5
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade ruby uri to 0.12.5.

Affected software

ProductAffectedFixed in
ruby uriAffected
  • <0.12.5
Fixed in
  • 0.12.5

AI-suggested

Upgrade the Ruby URI module to version 0.12.5, 0.13.3, or 1.0.4 or later, where this vulnerability has been fixed. Since this is a library vulnerability, applying the official patch by updating the affected Ruby versions is the recommended remediation. No additional mitigations are indicated.

Description

### Impact In affected URI version, a bypass exists for the fix to CVE-2025-27221 that can expose user credentials. When using the `+` operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. The vulnerability affects the `uri` gem bundled with the following Ruby series: * 0.12.4 and earlier (bundled in Ruby 3.2 series) * 0.13.2 and earlier (bundled in Ruby 3.3 series) * 1.0.3 and earlier (bundled in Ruby 3.4 series) ### Patches Upgrade to 0.12.5, 0.13.3 or 1.0.4 ### References * https://www.ruby-lang.org/en/news/2025/02/26/security-advisories/ * https://hackerone.com/reports/2957667

References

Community reviews

Loading reviews…